Vital RAW - World Champs Rock Sniping from Val di Sole 12

Day two, short, sweet and in the books as the bikes and riders beg for more. Martin Maes finds the rock goblin at the end. Yikes.

WIN A ROCKSHOX BOXXER & STEVIE SMITH SIGNED JERSEY

Credit: Steel City Media and Creative Concept
Create New Tag
12 comments
  • JCL

    9/9/2016 9:45 PM

    Anyone know what model camcorder that guy was using?

  • adrianperson01

    9/9/2016 9:25 PM

    Those poor, Poor wheels.

  • Sven Martin

    9/9/2016 4:51 PM

    Martin Maes FTW

  • onenerdykid*

    9/10/2016 10:37 AM

    what no one can make out on the videos (or pics) is just how deep the moon dust at VDS is. You think "ok, I'm going to put my front wheel there on that smooth bit" only to find out it's a 12" deep hole filled with dust and a death rock or two. This track is absolute carnage and chaos. And it's only getting worse as the riders come down. WORLD CHAMPS BABY!!!

  • canadmos

    9/9/2016 2:32 PM

    Is there a trick that anyone has to get Vital videos to play on a Chrome device?

  • russthedog

    9/9/2016 3:13 PM

    it works for me on chrome without issue, havent tried a mobile device though. I have a windows phone and the videos work half the time, might be my phone though. The slideshows done work at all, thats why im so grateful theres now a way to see it all in one page

  • Nozes

    9/9/2016 4:32 PM

    Chrome on pc and mobile,zero problems.

  • canadmos

    9/9/2016 6:02 PM

    I'm on a Chromebox, similar to a Chromebook. Not sure whats up, but only Vital vids don't load. All I see is the opening animated camera thing. Youtube videos on Vital work..

  • slicedsilver

    9/10/2016 2:59 PM

    Can you open the "devtools" on chrome? View -> Developer -> Developer Tools
    You could poke around there and try find the direct link to the video. It appears like the video link is printed to the console.

    http://v.vitalmtb.com/32218/vital-raw-world-champs-bike-abuse-from-val-di-sole--vid-32218--uid-2--xhd.mp4

  • MC_Leaning

    9/9/2016 9:09 PM

    I had the same thing yesterday. Couldn't get the vids to play on my chromebook or on chrome on my PC. No idea what the issue was. I tried running in incognito mode to make sure it wasn't an extension screwing it, but no dice. The ad just never played. I restarted my router and computers and it fixed it - no idea why...

  • deartist7

    9/9/2016 2:31 PM

    Martin's face at the end though.

  • MC_Leaning

    9/9/2016 2:27 PM

    Brooke's looking fast, but Danny's looking next level just skimming across the rocks!