Participating Members

  • Vital MTB member bturman
    109 bturman http://p.vitalmtb.com/photos/users/109/avatar/c50_twitter3_1382472127.jpg?1382471385 http://www.vitalmtb.com/community/bturman,109/all 08/01/09 1156 92 5961 1041 http://www.vitalmtb.com/community/bturman,109/setup 261 1125 2102 128 39
  • Vital MTB member mtbvicrush123
    28861 mtbvicrush123 /images/default/avatar/c50.png http://www.vitalmtb.com/community/mtbvicrush123,28861/all 12/17/13 http://www.vitalmtb.com/community/mtbvicrush123,28861/setup 1 1 1

my avid elixer 3's stufed up

Related:
Create New Tag

mtbvicrush123

Vital MTB member mtbvicrush123
28861 mtbvicrush123 /images/default/avatar/c50.png http://www.vitalmtb.com/community/mtbvicrush123,28861/all 12/17/13 http://www.vitalmtb.com/community/mtbvicrush123,28861/setup 1 1 1

Posts: 2

Joined: 12/17/2013

Location: AUS

12/19/2013 10:50 PM

today I washed my bike like usual and sat in upside down and took the wheels off so I could clean the forks e.c.t better. Then I put the wheels back on and went for a quik ride in the backyard to make sure everything was all working all good and I noticed that the brakes were working terible. They lost tons of power. Does anyone have any ideas on what has happened?

bturman

Vital MTB member bturman
109 bturman http://p.vitalmtb.com/photos/users/109/avatar/c50_twitter3_1382472127.jpg?1382471385 http://www.vitalmtb.com/community/bturman,109/all 08/01/09 1156 92 5961 1041 http://www.vitalmtb.com/community/bturman,109/setup 261 1125 2102 128 39

Posts: 1386

Joined: 8/1/2009

Location: On The Road, CO USA

Administrator

12/22/2013 3:08 PM

Avid brakes often act a little funny after being stored upside down. Try pumping the lever several times. You may need a bleed as well.

Like bikes? Hit Vital up on Instagram, Facebook, and Twitter.

mtbvicrush123

Vital MTB member mtbvicrush123
28861 mtbvicrush123 /images/default/avatar/c50.png http://www.vitalmtb.com/community/mtbvicrush123,28861/all 12/17/13 http://www.vitalmtb.com/community/mtbvicrush123,28861/setup 1 1 1

Posts: 2

Joined: 12/17/2013

Location: AUS

12/23/2013 3:35 AM

Yea I've tried that but didn't work, so I'm going to go get them bled at the bike shop.